[wp-hackers] RE: Changing MySQL minimum version?

Owen V. Gray ovgray at rogers.com
Sun Nov 19 04:53:18 GMT 2006

I just downloaded the latest nightly and got bitten by this change. I'm
running MySQL 3.23.58 on my local test server because that's what's
running on the virtual server I use. Some hosting providers are pretty
conservative about changing these things -- I gather things break when
MySQL is upgraded from 3.23.xx to 4.x+. I'm not going to move everything
off that server to one with MySQL 4.0 and PHP 5.0 just to contend with
this issue.

I hope the MySQL 4.0+ functionality is really needed for what you want
to do, because I suspect there will be others in your user base who will
be in the same position I am now in when 2.1 is released.  I suppose you
will tell those folks that they are SOL, that they can continue using
2.0 or just find a new host. I suppose they may ask whether you will
continue to support 2.0 at least to the extent of backporting security
fixes. You will want to have a plan for dealing with this issue before
releasing 2.1.

Meanwhile, I guess I can't follow along any more, at least for now. 

Best wishes,

Owen V. Gray

> According to the current minimum requirements page[1] WordPress
> requires only MySQL 3.23.23, but trunk revision 4455 introduced the
> use of SQL_CALC_FOUND_ROWS, which is available only in MySQL 4.0+
> Was this move deliberate?  If so, what is the new minimum MySQL
> version going to be for 2.1?
> [1] http://wordpress.org/about/requirements/

More information about the wp-hackers mailing list