[wp-hackers] RE: Changing MySQL minimum version?

Ryan Boren ryan at boren.nu
Sun Nov 19 05:34:42 GMT 2006

Owen V. Gray wrote:
> I hope the MySQL 4.0+ functionality is really needed for what you want
> to do, because I suspect there will be others in your user base who will
> be in the same position I am now in when 2.1 is released.  I suppose you
> will tell those folks that they are SOL, that they can continue using
> 2.0 or just find a new host.

The 4.0+ functionality sure is handy. We can either live without it, 
include some compatibility code that uses the new way for MySQL >=4.0 
and another way for <4.0, or provide a "crufty-old-platform.php" plugin 
that allows WP to run on ancient setups.  A plugin might be nice as it 
allows use to move certain things forward for the bulk of the user base 
to enjoy without baggaging them with legacy platform support.

> I suppose they may ask whether you will
> continue to support 2.0 at least to the extent of backporting security
> fixes. You will want to have a plan for dealing with this issue before
> releasing 2.1.

We've committed to supporting 2.0 for several years.  This change won't 
be going into 2.0, at least not any time soon and not until well after 
2.1 is out.


More information about the wp-hackers mailing list