[wp-edu] Jetpack error

Ken Newquist newquisk at lafayette.edu
Fri Jul 20 15:34:36 UTC 2012

Related to my previous post, I'm wondering if any colleges that used (or rather, tried to us) JetPack encountered errors connecting to the service. 

I've experimented with it on a personal site, and it worked just fine, but when I tried it on my dev site at the college, it failed with this error:

"Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host".

After finding this thread: 


we tried curling maneuver it suggested, and got back an error message of "HTTP/1.1 400 Bad Request"  along with an error of 

{"error":"home_missing","error_description":"The required \"home\" parameter is missing."}

I realize that this mailing lists for more general discussion topics, and not support requests, but a lot of the research we've done turns up problems with hosted sites on third party providers, not folks who do their hosting in house like many colleges do.

Ken Newquist
Director, Web Applications Development
Lafayette College
p: 610.330.5759
e: newquisk at lafayette.edu
web: http://sites.lafayette.edu/newquisk
podcast: http://sites.lafayette.edu/coffeebreak
cal: https://webmail.lafayette.edu/home/newquisk@lafayette.edu?fmt=freebusy

More information about the wp-edu mailing list