[wp-hackers] Script bundled with WordPress 'since' .. & theme requires version X

Drew xoodrew at gmail.com
Tue Dec 11 02:14:48 UTC 2012

The version pages in the Codex tell you which script versions shipped with
which release.




and so on.

Hope that helps,


On Mon, Dec 10, 2012 at 7:07 PM, Alexander Höreth <a.hoereth at gmail.com>wrote:

> Hey there,
> is there any way to figure out since which version a script is included in
> WordPress Core?
> There is a list of all scripts included, but it does not contain an 'since'
> [1]
> Wanted to use 'farbtastic' as fallback for the new color picker from 3.5.
> In trac there are already tickets from 2008 about it - when trying to
> enqueue it I only got it working 3.2 and newer.
> wp_enqueue_style( 'farbtastic' );
> > wp_enqueue_script( 'farbtastic' );
> Furthermore, not exactly the same topic:
> There is no "theme requires version X and is compatible up to version Y" on
> WordPress.org, is it? Wanted to install some themes featuring post
> thumbnail on 3.0 to test my plugin. First idea: 2012. It broke because of
> an missing multiuser function.
> Is this a bug which should be reported and/or patched? I didn't do so
> because the theme no where claims to be compatible down to 3.0.
> Best regards, hope you all get some sleep before 3.5 is released
> [1]
> http://codex.wordpress.org/Function_Reference/wp_enqueue_script#Default_scripts_included_with_WordPress
> _______________________________________________
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
> http://lists.automattic.com/mailman/listinfo/wp-hackers


"News is something someone wants suppressed. Everything else is just
-- Lord Northcliff <http://www.timberlinegardens.com>

More information about the wp-hackers mailing list