[wp-hackers] Script bundled with WordPress 'since' .. & theme requires version X

Alexander Höreth a.hoereth at gmail.com
Tue Dec 11 02:07:16 UTC 2012

Hey there,
is there any way to figure out since which version a script is included in
WordPress Core?

There is a list of all scripts included, but it does not contain an 'since'

Wanted to use 'farbtastic' as fallback for the new color picker from 3.5.
In trac there are already tickets from 2008 about it - when trying to
enqueue it I only got it working 3.2 and newer.

wp_enqueue_style( 'farbtastic' );
> wp_enqueue_script( 'farbtastic' );

Furthermore, not exactly the same topic:
There is no "theme requires version X and is compatible up to version Y" on
WordPress.org, is it? Wanted to install some themes featuring post
thumbnail on 3.0 to test my plugin. First idea: 2012. It broke because of
an missing multiuser function.
Is this a bug which should be reported and/or patched? I didn't do so
because the theme no where claims to be compatible down to 3.0.

Best regards, hope you all get some sleep before 3.5 is released


More information about the wp-hackers mailing list