[wp-hackers] WP Update Problems

John Bloch jbloch at olympianetworks.com
Mon Apr 5 22:40:26 UTC 2010

Hi everybody,

I've been having a helluva time trying to get the automatic updater to work
on my Media Temple's dedicated virtual server to no avail, and I was hoping
someone here could help me figure out why it won't run right.

I'm running an install of the 3.0-beta1 with 0 plugins. So here's what

I start the download process normally, by using the link under the dashboard
menu in the admin section and choosing 'Update Automatically.'  After
downloading the latest version (zipped), the script hangs up on unpacking
it, then finally throws a fatal error (WP_DEBUG has to be on) saying:

"*Fatal error*: Allowed memory size of 33554432 bytes exhausted (tried to
allocate 6968 bytes) in *
/var/www/vhosts/my/file/path/wp-includes/formatting.php* on line *1216"*


I have already tried all of the following solutions:*

   - *Setting the folder permissions (wp-content and my server's tmp) to 777
   (I went overboard and set the entire web accessible directory and all its
   contents, and subdirectories to 777, actually)*
   - *Making sure php's safe_mode was set to off*
   - *Setting the open_basedir local and global values to null*
   - *chowning the web accessible directory and all subdirectories and
   content so that apache:apache has ownership rights*
   - *scouring google searches, WP forums, and Media Temple's knowledge base
   for similar problems hoping to find a solution.*

*Plenty of people seem to have the same problem, but nobody seems to know
how to fix it. Do any of you have any ideas? Any advice you can give is
greatly appreciated.*
John P. Bloch

More information about the wp-hackers mailing list