[wp-hackers] Re: Changing MySQL minimum version
ryan at boren.nu
Sun Nov 19 20:43:44 GMT 2006
Owen V. Gray wrote:
>> The 4.0+ functionality sure is handy. We can either live without it,
>> include some compatibility code that uses the new way for MySQL >=4.0
>> and another way for <4.0, or provide a
>> "crufty-old-platform.php" plugin
>> that allows WP to run on ancient setups. A plugin might be
>> nice as it
>> allows use to move certain things forward for the bulk of the
>> user base
>> to enjoy without baggaging them with legacy platform support.
> I gather there is handy functionality in PHP5 too.
> If you are in any doubt about whether to include a plugin to ensure that
> those still using MySQL 3.23.xx can upgrade to 2.1, you could post a
> message in the dev blog at wordpress.org expressing that doubt, and see
> what reaction you get in the forums and elsewhere.
We've always been very conservative in bumping dependencies. We support
some truly ancient versions of PHP and MySQL, much to the chagrin of the
PHP and MySQL teams. However, 3.23 isn't even supported anymore, and
MySQL stopped hosting binaries for it. Perhaps it's time to move on.
More information about the wp-hackers