[wp-hackers] Re: Changing MySQL minimum version

Owen V. Gray ovgray at rogers.com
Sun Nov 19 14:30:07 GMT 2006

> The 4.0+ functionality sure is handy. We can either live without it, 
> include some compatibility code that uses the new way for MySQL >=4.0 
> and another way for <4.0, or provide a 
> "crufty-old-platform.php" plugin 
> that allows WP to run on ancient setups.  A plugin might be 
> nice as it 
> allows use to move certain things forward for the bulk of the 
> user base 
> to enjoy without baggaging them with legacy platform support.

I gather there is handy functionality in PHP5 too.

If you are in any doubt about whether to include a plugin to ensure that
those still using MySQL 3.23.xx can upgrade to 2.1, you could post a
message in the dev blog at wordpress.org expressing that doubt, and see
what reaction you get in the forums and elsewhere.

Owen V. Gray

More information about the wp-hackers mailing list