[wp-trac] [WordPress Trac] #38129: Rename `dynamic_sidebar` to something more understandable

WordPress Trac noreply at wordpress.org
Fri Sep 30 16:55:01 UTC 2016


#38129: Rename `dynamic_sidebar` to something more understandable
-------------------------+------------------------------
 Reporter:  ojrask       |       Owner:
     Type:  enhancement  |      Status:  closed
 Priority:  normal       |   Milestone:  Awaiting Review
Component:  Widgets      |     Version:  2.2
 Severity:  normal       |  Resolution:  invalid
 Keywords:  close        |     Focuses:
-------------------------+------------------------------
Changes (by mukesh27):

 * keywords:   => close
 * status:  new => closed
 * resolution:   => invalid


Comment:

 @ojrask it's not a good reason to rename that functions lots of theme and
 plugin use this function to register sidebar and to get sidebar in
 template so if WP developer change this function then all theme and plugin
 developer need to change this, if you want to change this then try to make
 new function like below.

 Add this code in '''function.php'''
 {{{#!php
 <?php
 function dynamic_widget_area( $sidebar_id ){
    dynamic_sidebar( $sidebar_id );
 }
 ?>
 }}}

 Call sidebar in template like '''page.php'''
 {{{#!php
 <?php
 dynamic_widget_area( $sidebar_id );
 ?>
 }}}

--
Ticket URL: <https://core.trac.wordpress.org/ticket/38129#comment:2>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform


More information about the wp-trac mailing list