[wp-hackers] Custom Types, 500 internal error, IIS6

Shasta Willson shastaw at gmail.com
Sun Aug 26 06:51:58 UTC 2012

I built a site located on an IIS6 server.  A month ago a custom type
with two taxonomies were working, with individual views and a couple
of custom pages that collected them in interesting ways functioning

Two days ago I got a frantic note from the client.  Creating a new
custom type and selecting "view" results in a 500 internal server
error.  During my explorations I also figured out that the pages that
display lists of the custom type (sorted by two taxonomies I built) no
longer display entries either.  I do not know if these are related
issues - my hunch is they may not be. (This is because a simple
taxonomy view page still shows entries, while the more complicated one
we're actually using doesn't.) In either case, every single custom
type shows a 500 when you try to view it from the admin or type in the

I do know the code hasn't been touched in three weeks.
I do not know if the server had been changed in any way.  I've asked.
I have checked the PHP error log -- no entries in some time. I checked
php.ini to make sure I had the right location.  Seems ok.
I tried setting the permalinks to something else, then back.  no dice.
I do have flush_rewrite_rules(); in strategic locations in the code
(after the custom type and both taxonomies).
So far as I know IIS doesn't use htaccess files, and I'm not sure how
to do the equivalent.  I've written to ask.
It's possible I changed something shortly before leaving town (I'm
technically on vacation) that didn't cause it to break until IIS
flushed a rule. The client added specs about names that meant I had to
change the slugs for several items in the last week.  They appeared to
be working, but it's the only thing I can think of that would cause
both the 500 error and the disappearing content. If so, I need to
figure out how to flush IIS so I can tell if I fix it back...

I'm not sure how useful links are, but here is a page showing a 500
local error for me:
This topic-taxonomy page (not in use) shows that the entries exist:
But this metro-area taxonomy page is not bringing up the entries it
should: http://pprc.org/index.php/metro/phoenix/  the template worked
three weeks ago.

Any help would be greatfully accepted.


More information about the wp-hackers mailing list