[wp-hackers] Exceeding upload_max_filesize when imported WP data

Christopher Ross cross at thisismyurl.com
Tue Mar 8 19:32:38 UTC 2011

Kevin, the importer is routinely a source grief but it's not really it's fault. Importing is extremely dependent on the server, so give this a try:

add a php.ini file to your root directory with the content:

upload_max_filesize = 10M
post_max_size = 10M

That should do it, otherwise add the same php.ini flle to your /wp-includes/ directory and the /wp-admin/ on some servers.

A quick way to test is to add the line <?php phpinfo();?> to the top of your header.php file, when you load the front of the site it'll display what the upload_max_filesize is for php, if the changes you made had an effect it'll show it here.


On 2011-03-08, at 3:06 PM, Kevin Newman wrote:

> No matter what I do when trying to upload a wordpress export to be re-imported I get the same error:
> Sorry, there has been an error.
> The uploaded file exceeds the <code>upload_max_filesize</code> directive in <code>php.ini</code>.
> I increased that value to 8MB via .htaccess (and WP reflects that next to the upload box), my file is 2.1MB, and gzipped it's only 300K or so. I still get exactly the message every time.
> Anyone else ever have this problem with the Wordpress importer?
> Kevin N.
> _______________________________________________
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
> http://lists.automattic.com/mailman/listinfo/wp-hackers


Christopher Ross
Online Portfolio - http://christopherross.ca
Personal Blog - http://thisismyurl.com

Fredericton - 506.238.4661
San Diego   - 858.201.4912

More information about the wp-hackers mailing list