[wp-hackers] Directory Writeable Error - File Uploads in 2011

Robert Lusby nanogwp at gmail.com
Wed Feb 2 12:12:59 UTC 2011


We created a website in 2010, and Media Uploads have been working fine.

We just tried our first upload for 2011 and get the following error:

*“filename.jpg” has failed to upload due to an error*
Unable to create directory
/var/somefilepath/httpdocs/wp-content/uploads/2011/02. Is its parent
directory writable by the server?

Now before saying "Check directory permissions", I'll let you know how it
currently stands:

1) /wp-content/uploads/ has full write permissions, and has been working
fine for creating all the folders in 2010.

2) The system automatically created the 2011 folder when the above upload
failed, and gave it 0777 permissions, and it's owned by Apache (the PHP user
on our system) (all of this is done automatically by WordPress).

3) So "wp-content/uploads" has write permissions. "wp-content/uploads/2011"
was created by WordPress, and has the right permissions. It can't create
wp-content/uploads/2011/02 .. ?

Output of ls -la:
drwxrwxrwx 6 apache apache 4096
drwxrwxrwx 2 apache apache 4096

Then inside 2010:
drwxrwxrwx 3 apache apache 4096
drwxrwxrwx 3 apache apache 4096
drwxrwxrwx 3 apache apache 4096

What am I missing? 2010 worked fine - 2011 has the right + same permissions
set but doesn't work. Sure it must be permission related somehow - but how?


More information about the wp-hackers mailing list