[wp-hackers] WP Update Problems

John Bloch jbloch at olympianetworks.com
Wed Apr 7 05:28:24 UTC 2010

Actually, I found the problem this morning. The hosting server had set the
owner and group of the files as root:root, but php runs as user apache. I
had already tried chown'ing the files to apache:apache (which works on most
server configs), but this one needed to be apache:root. The problem turned
out to be mostly on the part of the server, although WP wasn't throwing a
permissions error (which it's normally really good about).

The same problem also was causing directories to be non-writable, as well as
theme and plugin files, but all of those problems threw permissions errors.
As soon as I set everything to apache:root, all the problems went away.

John P. Bloch

On Wed, Apr 7, 2010 at 1:02 AM, Jeremy Visser <jeremy at visser.name> wrote:

> Hash: SHA1
> On 06/04/10 08:40, John Bloch wrote:
> > "*Fatal error*: Allowed memory size of 33554432 bytes exhausted (tried to
> > allocate 6968 bytes) in *
> > /var/www/vhosts/my/file/path/wp-includes/formatting.php* on line *1216"*
> Grasping at straws here, but if memory_limit didn't fix the bug, have
> you tried running an earlier version of WordPress (just for testing)?
> Could well be a bug in formatting.php creating an infinite loop or
> something. Or it could be a PHP bug. Not clear at this stage.
> The memory is being maxed in the function trailingslashit(), but that
> could be called from anything. Would be good if you could get a PHP
> traceback of some kind (off the top of my head, I don't know how to do
> that ? anyone want to pipe up?).
> Version: GnuPG v1.4.9 (GNU/Linux)
> iEYEARECAAYFAku8Ed0ACgkQvs6Qqs8TxBrvBQCg5eaGA7IokrwzZ80K+DVCZKc4
> cM8AnRgUYEj0yr3XSOIuBcI12XphJ6SB
> =/I5J
> _______________________________________________
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
> http://lists.automattic.com/mailman/listinfo/wp-hackers

More information about the wp-hackers mailing list