[wp-hackers] Meta tables: Take 5

scribu scribu at gmail.com
Mon Jul 27 11:42:37 UTC 2009

On Mon, Jul 27, 2009 at 5:24 AM, Jacob Santos <wordpress at santosj.name>wrote:

> Well, I think it is fine, except for object_id doesn't really have an
> explanation. Why not $id, instead? The problem is that it doesn't explain
> what the object part is, so it can be anything. It is the ID of the type you
> are looking for, so post, comment, category, etc. Why not just name it ID
> and leave out the question of what 'object' means. People understand what ID
> means.

I named it object_id because it was supposed to replace post_id and user_id.

wp_term_relationships also uses object_id.

The only tables that use ID are wp_posts and wp_users.

So object_id seemed more consistent. Anyway, let's not bikeshed about this
topic any further.


More information about the wp-hackers mailing list