[wp-hackers] Idea: Rename the Excerpt to something accurate

scribu scribu at gmail.com
Sat Feb 28 19:20:54 GMT 2009

On Sat, Feb 28, 2009 at 7:35 PM, Jeremy Clarke <jer at simianuprising.com>wrote:

> IMHO whatever function is used to show these lead-ins needs to accept
> a wp_parse_args() set of arguments that allow for things like
> length=50, before=$before_text and skip-auto=1. As it is the function
> is basically useless compared to the rest of WP and just isn't up to
> par/standards/expectations.
> Everyone always says "so write a patch" but its hard when the existing
> function is held back by its history. the_summary() could be a way
> around that, though I'd be happy to just let loose whoever still has
> that second parameter and move on with our excerpting lives.
> Controlling excerpts with arguments isn't plugin territory, it should
> definitely be in core. There should also be a filter on them and THAT
> is plugin territory.

+1. There should definetly be a more powerfull template tag for showing
excerpts / summaries / blurbs. the_summary() would be a good name for it.


More information about the wp-hackers mailing list