[wp-hackers] Storing Arbitrary Data as Custom Post Types

Otto otto at ottodestruct.com
Wed Dec 9 18:43:21 UTC 2009

On Wed, Dec 9, 2009 at 10:19 AM, Dougal Campbell <dougal at gunters.org> wrote:
> In a nutshell, my proposal was going to be that we use a naming convention
> like: [area]:[slug]:[name]
> For example, if you had a plugin named "Tweet Fu" (which has the slug
> 'tweet-fu' in the respository), you might have an option named:
> plugin:tweet-fu:last_tweet_timestamp
> Or if you have a theme that saves its own option:
> theme:my-theme-name:header_image_filename

Generally speaking, most plugins should be using a single option
holding an array of their settings. I tend to go with
pluginname-options, personally.

Any "standard" should take this into account, as keeping every option
in a separate row can be bad practice.

Sent from Memphis, TN, United States

More information about the wp-hackers mailing list