[wp-hackers] Seeking feedback on Plugins UI

DD32 wordpress at dd32.id.au
Thu Jun 5 07:14:01 GMT 2008

On Thu, 05 Jun 2008 16:51:10 +1000, Stefano Aglietti <steagl4ml at gmail.com>  

>> I have not got the next install ui up yet, However:
>>  * Clicking Install will most likely bring up a thickbox page with  
>> fuller
>> details about the plugin, Much like the WordPress.org site, Once the  
>> users
>> had a chance to look at the full details, They can confirm installation.
>> Thoughts on the Layouts?
> A look like the one for PressThis screen, with tabs with same info you
> have on plugin repository, like description, installation, FAQ, i
> would miss the screenshot that is not so usefull. This info will be
> catched on demand using ajax

Much the same as the Media uploader, So a similar format to Press This  
too, just not in its own window :)

Caching the information clientside while flipping through the  
Description/FAQ/Installation tabs would be done of course.

Ajax would probably not be needed at all, Just Load the page in an iframe  
in thickbox(like the media uploader) The delay in WordPress querying  
wordpress.org's plugin database should be minimal for most webhosts  
(Fetching external data is generally pretty quick)

>> Anything missing? A detail you'd like to see in the table? (ie. Recently
>> updated, Or maybe the total number of ratings which have gone into that
>> rating)
> Would be nice having the version of WP for the plugin works, unless
> the list it's already filtered

Ah yes, Compatibility.

The list could be filtered server side to not show plugins which require a  
later version of WordPress, However, I think this might work instead:

Displaying the "Requires" & "Tested up to" field is something that would  
be on the detailed view, But also would be good on the plugins list,  
Perhaps differing background colours (As well as a value shown somewhere)
Green: Known to be compatible
Yellow: Has not been tested with the current version of wordpress
White: Unknown tested up to version
Red: Plugin requires a later version of WordPress

The benefit of this (rather than filtering out incomparible plugins) would  
be to allow users to know that there *is* a plugin which will fill the use  
they want, However, to use it, they'll need a later version of WordPress.  
(Installation would also not be offered if the plugin requires a later  

Maybe another colour for "Has been tested to work with this branch"(eg.  
Running 2.6.1, plugin has been tested up to 2.6.0, It should not give the  
same warning as if it was only tested up to 2.3 or 2.5)

Or even a column "Compatible": "Yes", "Maybe: Tested to 2.5.2", "Unknown",  
"Requires WordPress 2.7"

Just quick thoughts there on the colours.

More information about the wp-hackers mailing list