[wp-hackers] WordPress Visual Editor Broken

Noel Jackson noel at eight6.com
Wed Jul 9 03:05:32 GMT 2008

I've experienced issues like this with Solaris 10. Some unixes treat  
getcwd() and realpath() differently than how they should be (really a  
PHP problem).

What I did to fix it was chmod +x anything anything in the webroot path.

from php.net:

On some Unix variants, getcwd() will return FALSE if any one of the  
parent directories does not have the readable or search mode set, even  
if the current directory does. See chmod() for more information on  
modes and permissions.

Maybe that's the culprit.

On Jul 8, 2008, at 9:46 PM, Chris Poteet wrote:

> I'm sorry to post again, and I hope this hasn't been posted before.
> For some reason, on two of my WordPress installs the visual editor
> does not work.  I've checked the plugins, and I even tried 2.6b2 but
> still no go.  Anyone else?
> Screenshot: http://screencast.com/t/C0ioSbD9N
> _______________________________________________
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
> http://lists.automattic.com/mailman/listinfo/wp-hackers

More information about the wp-hackers mailing list