[wp-hackers] Forced Upgrades after a failed "completion"

Daniel Cameron dan at scatter3d.com
Tue Sep 25 22:40:53 GMT 2007

Is there anyway for you to force an upgrade after a failed completion?

Long story (sort of) short; I'm using SVN to upgrade all of my sites with my
own repository because of a stupid svn configuration mistake on one of the
files resulted in the the automatic svn update from completing, some files
were added/deleted/updated and some were left to 2.2.3. Of course I didn't
check my logs and went ahead to load a few of the sites admins. As _we_
would expect the outcome was not good, the main error refereed to the
"'prefix_terms' doesn't exist" (sorry I should have kept the full output,
instead I'm relying on Google History which I don't have any
privacy/security qualms :) ).

I ended up restoring the db to the latest dump and running the upgrade
script again. What I can't explain is how the upgrade worked against a
backup that was *after* the initial 2.3 upgrade, I did get duplicate errors
which were telling me that those portions of the db were already

Like I said I'm not sure how this worked and I can only blame myself for
overlooking what caused the problem, at least the second oversight resulted
in a second upgrade that "fixed" the site/db.

So what is the Upgrade checking prior to running, is there a flag to
manually reset (which was somehow reset in my import) would it be to
dangerous to add a "let's try again" for core updates? Or should I have not
admitted this and kept it to myself?


Dan Cameron

More information about the wp-hackers mailing list