[wp-hackers] Plugin Activation

Andy Staines andy at yellowswordfish.com
Sun Jun 17 22:55:01 GMT 2007

That's not something I'm ever really going to know. Yes - it  
certainly looks like 4.1.20 has a table creation problem and if I  
find what it is I can cater for it. But that still doesn't explain  
the missing menu which is the real puzzle.

On 11:10  PM |  Sun 17 Jun 07, at 11:10  PM |  17 Jun 07, Matt wrote:

> Do any of your other users use MySQL 4.1.20 and NOT have the  
> problem? If
> not, get your users on MySQL 4.1.21 or MySQL 5.x. It could be a bug  
> in MySQL
> 4.1.20...
> On 6/17/07, Andy Staines <andy at yellowswordfish.com> wrote:
>> I asked three or four weeks back if anyone had any idea why one user
>> of my forum plugin was not seeing the admin menu (under 'Manage').
>> This went unresolved but there is something weird going on so I
>> thought I'd have another go to see if anyone had any ideas.
>> I now have three users with this problem (out of a large number who
>> don't) - two are using 2.2 and one 2.1. The only thing they seem to
>> have in common is they are all using MySQL 4.1.20 - and, what's more,
>> the activate hook that creates the tables is also either failing, or,
>> MySQL 4.1.20 doesn't want to do it. So these three end up with no
>> tables created, an incomplete activation of the plugin and no admin
>> menu!
>> The questions raised by this are - why should 4.1.20 fail to create
>> the tables and why should this stop the menu from being created. I
>> can see no relationship between the db and the menuing system. Plus,
>> in all cases, the plugin appears correctly in the 'active_plugins'
>> option record.
>> I would really like to sort this out if possible but I am completely
>> stuck for ideas. Can anyone advise? (On my original query I had
>> responses to do with the activate hook usage and the add_submenu_page
>> usage but these work fine 99.9% of the time and are correct.
>> Something else seems to be in play here).
>> As an extra item, I tried the simple expedient in testing of forcing
>> the tables to fail via code. This led to the plugin activation page
>> returning the message: 'Plugin could not be activated because it
>> triggered a fatal error' but it WAS in fact activated (albeit
>> crippled) and I still got the menu appearing! I assume this is a bug
>> in the plugin activation code.
>> This is driving me nuts and my hair is turning white. OK - it was
>> already white but now it's falling out. Can anyone point me in the
>> right direction?
>> regards
>> Andy
>> _______________________________________________
>> wp-hackers mailing list
>> wp-hackers at lists.automattic.com
>> http://lists.automattic.com/mailman/listinfo/wp-hackers
> -- 
> Matt (speedboxer at gmail.com)
> http://mattsblog.ca/ | http://livemp.net/
> _______________________________________________
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
> http://lists.automattic.com/mailman/listinfo/wp-hackers

More information about the wp-hackers mailing list