[wp-hackers] Editor colSpan bug?

Chris chris.hearn01 at ntlworld.com
Wed Jun 6 12:18:29 GMT 2007

Hi Doug,
the other way round!
I enter colspan="2", which IS valid markup.

When post is saved, it gets changed to colSpan="2", with capital S, 
which is NOT valid markup.


Doug Stewart wrote:
> On 6/6/07, Chris <chris.hearn01 at ntlworld.com> wrote:
>> Hi,
>> Entering a table in the Tinymce editor, (using the code tab) changes <th
>> colspan="2> to <th colSpan="2"> when post is saved.
>> I have tried to find the cause, and found that this occurs using
>> Wordpress v2.1 or 2.2, with the Visual Editor selected to Yes in
>> profile, and unfiltered html capability = on.
>> If visual editor setting is off (so only code page shows) this does not
>> occur, and the post is saved correctly. I have not managed to find where
>> this occurs.
>> This appears to be a bug - I have tried searching wordpress trac and the
>> Moxiecode buglist, dont't see anything that describes this.. would one
>> of you more experienced guys be able to confirm this is a known (or
>> unknown!) bug?
> I'm confused.  It looks as though you're trying to use invalid markup
> and tMCE is correcting it for you. What's the problem?

More information about the wp-hackers mailing list