[wp-hackers] Sharing Users/authentication

Chris Lott chris.lott at gmail.com
Thu Aug 30 21:44:21 GMT 2007

So, I cleared everything out (de-activated plugin, deleted rows from
wp_options, copied fresh plugin files) and tried again and here is
what is happening... slightly different now.

Starting with two blogs without the plugin. I install the plugin on
the first (master) blog. Activate it. No errors. When I look at the
options it is showing the right database and prefix. Note: I can't
logout of that blog, though... when I try to sign out I just get
redirected to the same page in the control panel area I am on.

At this point I see only one entry in the wp_options table.

Go to second (slave) blog. Activate plugin. Go to options, put in
database name (it is a diff database) and prefix (which is the same).
No errors. I can sign out.

Back to master blog, still no errors, can;t sign out.

Back to slave blog, can't sign in with any usernames from the Master
blog (says invalid username), old sign-ins from the slave blog still

In the master blog the wp_options line has this value:

The slave blog has this:

No errors showing, but nothing seems to be happening. It's mystifying.


On 8/30/07, Stephen Rider <wp-hackers at striderweb.com> wrote:
> Hi --
> First off, This isn't my plugin, it's Curt Woodard's.  I've been
> helping with testing and making suggestions, though, so I'm pretty
> familiar with it.  :)
> Questions:
> Are the two blogs on the same or different database?
> Same or different username/ password?
> Somehow it seems that the writing of options isn't working
> correctly.  This may be a database problem of some sort.  I don't see
> any problems with the related code (yet).
> When exactly do you get these errors?  immediately when you activate
> the plugin?  When you change the settings?
> Stephen
> On Aug 30, 2007, at 2:51 PM, Chris Lott wrote:
> > Stephen:
> >
> > I'm trying this on a faculty blog and it worked fine on the first
> > blog... but on the second it gives this when I try to activate the
> > plugin:
> >
> > WordPress database error: [Incorrect table name 'usermeta']
> > SELECT * FROM ``.usermeta WHERE user_id = '1' AND meta_key LIKE 'wp_%'
> <snip>
> _______________________________________________
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
> http://lists.automattic.com/mailman/listinfo/wp-hackers

Chris Lott

More information about the wp-hackers mailing list