[wp-edu] WordPress for iOS app-- does it work with multisite?

Joseph Ugoretz joseph.ugoretz at mhc.cuny.edu
Wed Aug 7 14:37:23 UTC 2013

I don't have very many users working with the iOS app, but it definitely does work with our multisite install.  Adding the first blog works (and the title is correct) and adding additional blogs is also fine.  We're on 3.6, if that matters. (latest version of the app).

The only hint I can give in what is basically a "works for me" response (don't you hate those?), is that we are on a subdirectory, not a subdomain, multisite install.  (largish install with +3000 users and sites).

Joseph Ugoretz, PhD
Associate Dean
Teaching, Learning and Technology

Macaulay Honors College
The City University of New York
35 West 67th St.
New York, New York 10023
TEL 212-729-2920
FAX 212-580-8130
joseph.ugoretz at mhc.cuny.edu

On Aug 7, 2013, at 10:24 AM, Juliana Perry <jperry02 at brynmawr.edu>

> Dear all, 
> Have any of your users had luck using the WordPress for iOS app with your multisite installs? Ours have been having some problems. I tried to post a question to the WordPress for iOS forums first, but get an error any time I try to post, so I am hoping some of you have experience with this app, particularly since wp-edu users are more likely to have similarly large multisite installs. 
> Whenever any of our iOS device users try to add a second blog within our multisite install (blogs.brynmawr.edu), the app gets stuck at "Reading blog options" and fails to add the blog. 
> We're on WordPress 3.5.1 and trying this with the latest version of the iOS app (tried on a couple of different iPads and an iPhone 5 with the same result). 
> What happens: 
> - I can add one blog (say, techbar.blogs.brynmawr.edu) just fine. 
> - That one blog appears correctly, except for the Site Title, which is always the title of the first blog in the user's list of sites, regardless of which blog I add. 
> - If I try to add a second blog within the same multisite install (say, facultypublications.blogs.brynmawr.edu) , it hangs on "reading blog options" forever. 
> - Adding the main blog (just blogs.brynmawr.edu) first doesn't seem to help. 
> What we've tried: 
> - This looks similar to some older forum posts such as http://ios.forums.wordpress.org/topic/iphone-app-crashes-when-adding-a-blog?replies=32 but that's not quite our setup and the post implies that that particular issue has been patched...? 
> - Our XMLRPC settings appear to be correct per the app FAQ 
> - The debugger http://dev.ios.wordpress.org/extra-debug/ log files don't seem to reveal an error or crash. 
> It looks like the app is intended to work with multisite, but I'm not sure if we have something oddly configured (our install is certainly old enough to have some quirks), or if the app isn't currently playing well with multisite (or larger multisite installs)? 
> Thank you, 
> Juliana
> ---
> Juliana Perry
> Web Services Project Manager
> Bryn Mawr College
> 610-526-7554
> _______________________________________________
> wp-edu mailing list
> wp-edu at lists.automattic.com
> http://lists.automattic.com/mailman/listinfo/wp-edu

More information about the wp-edu mailing list