[buddypress-trac] [BuddyPress Trac] #7103: Embeds: rename `BP_oEmbed_Component` class

buddypress-trac noreply at wordpress.org
Tue May 31 12:52:59 UTC 2016

#7103: Embeds: rename `BP_oEmbed_Component` class
 Reporter:  DJPaul        |      Owner:
     Type:  defect (bug)  |     Status:  new
 Priority:  normal        |  Milestone:  2.6
Component:  API           |    Version:
 Severity:  normal        |   Keywords:
 Please can the `BP_oEmbed_Component` class be renamed to
 That way, it'll get picked up by the autoloader, then we can remove the
 `require_once` hack at the top of `class-bp-activity-oembed-

 I really dislike the `oEmbed` capitalisation but will let it pass because
 it's more readable this way.

 I also dislike the fact this class is called a "component" which has a
 very specific meaning in BuddyPress, but I don't have a better suggestion.

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/7103>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list