[wp-trac] [WordPress Trac] #14786: It's WP_Http_ExtHTTP not WP_Http_ExtHttp

WordPress Trac wp-trac at lists.automattic.com
Mon Sep 6 03:39:15 UTC 2010

#14786: It's WP_Http_ExtHTTP not WP_Http_ExtHttp
 Reporter:  hakre         |       Owner:                        
     Type:  defect (bug)  |      Status:  new                   
 Priority:  normal        |   Milestone:  Awaiting Review       
Component:  General       |     Version:  3.0.1                 
 Severity:  normal        |    Keywords:  has-patch dev-feedback

Comment(by jacobsantos):

 Replying to [comment:3 hakre]:
 > fopen WP_Http might be considered obsolete since PHP 4.3 requirements.
 Should be the same as streams WP_Http.

 {{{$context}}} was added in PHP5, which streams relies on. While streaming
 was added in PHP4.3, it didn't support HTTP that is available in PHP5.

Ticket URL: <http://core.trac.wordpress.org/ticket/14786#comment:7>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software

More information about the wp-trac mailing list