[wp-trac] [WordPress Trac] #12862: Actively encourage PHP 5 upgrades

WordPress Trac wp-trac at lists.automattic.com
Thu Oct 28 19:36:56 UTC 2010

#12862: Actively encourage PHP 5 upgrades
 Reporter:  dougal           |       Owner:     
     Type:  feature request  |      Status:  new
 Priority:  low              |   Milestone:  3.1
Component:  General          |     Version:  3.0
 Severity:  normal           |    Keywords:     

Comment(by westi):

 Replying to [comment:11 aaroncampbell]:
 > While I agree that code in core to tell people to upgrade needlessly is
 clearly bloat (like telling IE 6 users to switch to Firefox, etc), I think
 this differs in two ways:
 >  1. It's not arbitrary.  Version 3.2 will require PHP 5.  For those on
 PHP 4 who use auto-update and don't look at the release notes, they're
 going to be quite surprised when they try to upgrade to 3.2.
 >  1. It's basically temporary code.  It only "bloats" a single release.
 Any code that's put in now can be removed from trunk as soon as the 3.1
 branch is created.
 > However, I don't know if this needs to be a notice in the admin.  We
 could just as easily make the upgrader fail out with a message to the user
 if they try to upgrade to 3.2 and don't have PHP 5.2+.

 As far as I know the upgrader all ready does this and has done since
 possibly 2.9 as we upped the required mysql version

Ticket URL: <http://core.trac.wordpress.org/ticket/12862#comment:12>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software

More information about the wp-trac mailing list