[buddypress-trac] [BuddyPress Trac] #7277: BP 2.8 - Prevent loading if PHP < 5.3

buddypress-trac noreply at wordpress.org
Thu Dec 29 20:24:33 UTC 2016

#7277: BP 2.8 - Prevent loading if PHP < 5.3
 Reporter:  r-a-y                  |       Owner:
     Type:  defect (bug)           |      Status:  new
 Priority:  highest                |   Milestone:  2.8
Component:  Core                   |     Version:
 Severity:  blocker                |  Resolution:
 Keywords:  has-patch 2nd-opinion  |
Changes (by boonebgorges):

 * keywords:  needs-patch => has-patch 2nd-opinion
 * priority:  high => highest
 * severity:  critical => blocker


 [attachment:7277.diff] is a first pass. There's a lot of red and green
 because I moved the `BuddyPress` class to its own file. This independently
 seems like a good thing. It also allows us to keep bp-loader.php minimal,
 which makes it easier to ensure that it remains compatible with PHP 5.2
 (or whatever WP's minimum version is in the future).

 BP 2.8 should be able to drop all of the stuff introduced in #7196 - since
 you'll need to be running PHP 5.3 to run BuddyPress 2.8, BP 2.8 doesn't
 need to warn 5.2 sites about upgrading anymore :-D

 Thoughts welcome - especially @DJPaul and @johnjamesjacoby

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/7277#comment:3>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list